Sie sind nicht angemeldet.

Lovato

the knowledge

  • »Lovato« ist der Autor dieses Themas

Beiträge: 154

CPU: AMD Phenom 955 4x3Ghz

RAM: 6GB

Graka: ATI Radeon 4850

OS: Windows 7

  • Nachricht senden

1

04.11.2009, 23:38

LogMeIn Hamachi unter Windows 7 einrichten/konfigurieren

Nur registrierte Mitglieder können Bilder in voller Auflösung sehen sowie Dateianhänge herunterladen. Zur Registrierung.

In diesem Tutorial beschreibe ich, wie ihr die VPN Software LogMeIn Hamachi so konfigurieren könnt, dass ihr mit Freunden im Netzwerk problemlos spielen könnt.

Es wird ebenfalls beschrieben, wie der unter Windows 7 bekannte Fehler, dass man keine anderen Teilnehmer oder Spiele findet, beheben kann.

Ihr solltet bereits die neuste Version von LogMeIn Hamachi heruntergeladen und installiert haben.

Im ersten Schritt sind einige Anpassungen an der Netzwerkkonfiguration bzw. dem von Hamachi erstellten Adapter notwendig.
Hierhin kommt man am schnellsten durch Öffnen des Startmenus, Eingabe von "ncpa.cpl" und einem Druck von [Enter].
Im neuen Fenster wird das Menu durch einmaliges Drücken der [ALT]-Taste geöffnet. Dann wählen wir Erweitert / Erweiterte Einstellungen. Hier sorgen wir mit den Buttons dafür, dass die Hamachi-Verbindung als erster Eintrag in der Liste steht:


Das Fenster wird mit OK geschlossen.


Jetzt müssen die Einstellungen des Netzwerkadapters Hamachi angepasst werden. Dazu einen Rechtsklick auf Hamachi und Einstellungen auswählen. In der Liste wählen wir den Eintrag "Internet Protocol Version 4" und Eigenschaften -> Erweitert auswählen.


Im neuen Fenster wird zunächst die Automatische Metrik deaktiviert und die Interface Metrik auf 10 gesetzt. Dann einen Klick auf das Standardgateway (normalerweise 5.0.0.1) und bearbeiten auswählen.
Hier muss ebenfalls die Automatische Metrik deaktiviert, und die Metrik auf 1500 gesetzt werden.
Die Einstellungen sollten dann folgendermaßen aussehen:



Danach sollte der Computer neu gestartet werden, damit alle Einstellungen angewendet werden. Hamachi ist nun fertig konfiguriert.

Problem, dass keine Spiele/Mitspieler gefunden werden:

Unter Windows 7 gibt es allerdings das Phänomen, dass zwar die Hamachiverbindung ohne Probleme aufgebaut werden kann, auch Ping oder Netzwerkfreigaben problemlos klappen, die Teilnehmer sich aber trotzdem gegenseitig nicht im Spiel finden können.
Dies liegt daran, dass die versendeten Broadcasts nicht über die Hamachi Verbindung übertragen werden.
Um dies zu ermöglichen ist ein kleines Zusatzprogramm, der HamachiBroadcastFix notwendig, welches für die Dauer der Verbindung im Hintergrund laufen muss. Dieses kann hier bezogen werden: http://rapidshare.com/files/222589683/Ha…roadcastFix.zip (Alternativ befindet sich die Datei im Anhang)
Dieses Programm benötigt die Library WinPcap welche hier heruntergeladen werden kann: http://www.winpcap.org/install/default.htm


Um spielen zu können muss zuerst Hamachi gestartet, sowie die Verbindung hergestellt werden. Danach wird die Datei HamachiBroadcastFix.exe als Administrator gestartet (Rechtsklick -> Als Administrator ausführen).
In dem DOS Fenster müssen die folgenden Daten eingegeben werden:
  • eure Hamachi IP (steht im Hamachi Hauptfenster)
  • Nummer des Netzwerkinterfaces welches in das lokale LAN bzw Internet zeigt (normalerweise Name der Netzwerkkarte)
  • Nummer des Hamachi-Netzwerkinterfaces

Die Ausgabe sollte in etwa so aussehen:


Jetzt ist es problemlos möglich über Hamachi unter Windows 7 zu spielen!


Lovato 4
win7forum.de
»Lovato« hat folgende Datei angehängt:
Lovato - win7forum.de Super Moderator

Klimbum

unregistriert

2

06.11.2009, 23:39

Super, vielen Dank für das Tutorial! Endlich sehe ich den CoD (Call of Duty - Modern Warfare) Server meines Freundes auch über Hamachi!

Vielen Dank liebes Team!!!

Lovato

the knowledge

  • »Lovato« ist der Autor dieses Themas

Beiträge: 154

CPU: AMD Phenom 955 4x3Ghz

RAM: 6GB

Graka: ATI Radeon 4850

OS: Windows 7

  • Nachricht senden

3

08.11.2009, 20:49

Vielen Dank für die Info - freut mich, dass ich Dir helfen konnte!
Lovato - win7forum.de Super Moderator

4

11.11.2009, 18:04

Schließe mich dem Dank an :)

5

15.11.2009, 05:38

sauber

wunderbar!

besser gehts nicht

danke!

Schnucke

unregistriert

6

20.11.2009, 09:28

Super

Vielen Vielen dank für die super Anleitung. War sicherlich ein wenig Recherche notwendig.

Lovato

the knowledge

  • »Lovato« ist der Autor dieses Themas

Beiträge: 154

CPU: AMD Phenom 955 4x3Ghz

RAM: 6GB

Graka: ATI Radeon 4850

OS: Windows 7

  • Nachricht senden

7

30.11.2009, 19:42

Ich habe heute die folgende Zuschrift zu diesem Thema erhalten:

Zitat

hi
also sobald man hamachi installiert hat wird ja ein 2. netzwerk erstellt was dann lautet "Netzwerk 2" so und da steht aber kein internet zugriff ... aber müsste da nicht "lokal" stehen ? oder sowas halt ... bei vista steht das zum beispiel da .. eingestellt ahb ich es auch schon nach deiner anleitung und ich hab das auch gemacht mich dem boardcast und so nur cod 2 geht trotzdem nicht .. kp woran es liegt und andere spiele hab ich noch nicht getestet ... in wie vielen fällen funktioniert das?
lG Petrol
Ich poste diese hier, damit auch andere profitieren können, welche unter Umständen die gleichen Probleme haben.


Habe leider auf meinem Rechner aktuell kein Hamachi installiert, deswegen kann ich es nicht unmittelbar nachvollziehen. Allerdings hieß meine Netzwerkschnittstelle welche installiert wurde nicht "Netzwerk 2", sondern eben Hamachi. Bist du sicher dass diese anders heißt, bzw hast du die neuste LogMeIn Hamachi Version?
Gab es bei dem Broadcast fix irgendwelche Fehler? Wenn dieser gestartet ist, und korrekt arbeitet, müssten wenn du ein spiel suchst bzw. aufmachst dort im Konsolenfenster (das muss offen bleiben!) neue Einträge hinzukommen wie "Forwarding Broadcast" oder so. Tauchen die bei dir auf?

Weiterhin bedenke bitte, dass diese Konfiguration unter Umständen auch bei der Person durchzuführen ist, mit der du spielst, sofern diese ebenfalls Windows 7 hat. (Soweit läuft es bei Vista auch nicht out of the box, hier müssen auch einige Anpassungen vorgenommen werden).

Zur abschließenden Frage kann ich nur sagen, dass ich bis jetzt nur positives Feedback zu dem Tutorial bekommen habe. Auch bei allen die ich persönlich kenne, hat es nach dieser Anleitung geklappt.

Grüße,
Lovato
Lovato - win7forum.de Super Moderator

8

30.11.2009, 21:46

aso ok .. zu info das heißt bei mir auch hamachi also als netzwerk 2 ... ach kp was da los is ^^ naja trotzdem danke

9

27.12.2009, 20:03

ich blick des mit des Dos nicht was ich da alles eingeben muss :D

10

27.12.2009, 20:53

Hallo!

Erst mal vielen Dank für die Anleitung. Ich benutze Hamachi (Version 1.0.3) schon seit langem problemlos unter Windows XP, um darüber mit Freunden Warcraft III/The Frozen Throne zu spielen. Mittlerweile bin ich auf Windows 7 und das neue Hamachi 2 umgestiegen, allerdings habe ich massive Probleme mit der Konfiguration. Ich bin nun schon den ganzen Tag am googeln und rumprobieren und komme einfach nicht weiter. Hamachi ist korrekt installiert, die Firewall richtig konfiguriert, in der Liste der erweiterten Einstellungen steht Hamachi ganz oben. Schwierigkeiten bereitet die Interface Metric. Der Wert ist dort standardmäßig auf 4235 eingestellt, ein von mir gehostetes Spiel kann so nicht erkannt werden. Wenn ich den Wert auf 10 ändere funktioniert zwar Hamachi und meine Spiele werden gefunden, allerdings kann mein Browser dann keine Internetseiten mehr anzeigen. Dazu kommt, dass bei jedem neuen Einwählen ins Internet die Interface Metric auf den Wert 4235 zurückgesetzt wird, obwohl die Checkbox "Automatische Metrik" deaktiviert ist.

cmd => route print liefert folgende Ergebnisse:

1. Vor ändern der Metric auf 10 / nach Neueinwählen ins Internet:



2. Nach ändern der Metric auf 10:




Ich bin mittlerweile ganz schön am Verzweifeln und würde mich wirklich freuen, wenn mir jemand helfen könnte!

Lovato

the knowledge

  • »Lovato« ist der Autor dieses Themas

Beiträge: 154

CPU: AMD Phenom 955 4x3Ghz

RAM: 6GB

Graka: ATI Radeon 4850

OS: Windows 7

  • Nachricht senden

11

28.12.2009, 01:31

@Carhartt:
ich blick des mit des Dos nicht was ich da alles eingeben muss :D

Es sind eigentlich wie beschrieben nur 3 Dinge:
Zuerst deine Hamachi IP welche in deinem Hamachi Fenster steht (Form: 5.x.x.x), dann ENTER drücken)
Du erhälst dann eine Liste der Netzwerkadapter in deinem PC in diesem DOS Fenster mit entsprechenden Nummern davor. Du musst dann die richtigen Nummern eingeben (s. HoTo oben).
Sollte das nicht klappen, dann poste einfach einen Screenshot von dem DOS-Fenster nachdem du die IP eingegeben und mit Enter bestätigt hast, dann können wir dir mit hoher Wahrscheinlichkeit die richtigen Nummern sagen :)

@JensH: Deiner Fehlerbeschreibung nach zu urteilen könnte das Problem sein, dass du nur EINE Metrik geändert hast.
Es gibt aber 2: Die direkt bei den erweiterten TCP/IP-Eigenschaften, sowie die Metrikeinstellungen zum Gateway selbst (siehe Anleitung, da sind ja 2 Screenshots zu den Metrikkonfigurationen, beide Fenster sollten bei dir genau so aussehen)
Wegen dem zurücksetzen der Einstellungen: Deine Routingtabelle sieht so aus als würdest du dich direkt (über Modem, also ohne Router) ins Internet einwählen. Ich kann da mangels Erfahrung wenig zu sagen, aber es kann schon sein, dass die Einstellungen bei Neueinwahl zurückgesetzt werden, da du ja damit quasi jedes Mal eine neue Verbindung aufbaust.

Poste doch einfach noch einmal ob die Metrik-Einstellungen wirklich genau so gesetzt waren, bzw. ob das Problem noch existiert :)
Lovato - win7forum.de Super Moderator

12

28.12.2009, 09:24

Hallo! Erst mal Danke für die zügige Antwort :)
Leider hat sich das Problem nicht gelöst...



@JensH: Deiner Fehlerbeschreibung nach zu urteilen könnte das Problem sein, dass du nur EINE Metrik geändert hast.
Es gibt aber 2: Die direkt bei den erweiterten TCP/IP-Eigenschaften, sowie die Metrikeinstellungen zum Gateway selbst (siehe Anleitung, da sind ja 2 Screenshots zu den Metrikkonfigurationen, beide Fenster sollten bei dir genau so aussehen)


Im vorliegenden Beispiel hatte ich tatsächlich nur die Einstellung "Schnittstellenmetrik" verändert (wodurch meine Spiele unter Hamachi erkannt werden können). Wenn ich alles so konfiguriere wie von dir beschrieben (siehe Screenshot) ändert sich allerdings auch nichts weiter, mein sonstiger Internetverkehr ist lahmgelegt.

Einstellungen:


route print im Anschluss:



Zitat

Wegen dem zurücksetzen der Einstellungen: Deine Routingtabelle sieht so aus als würdest du dich direkt (über Modem, also ohne Router) ins Internet einwählen. Ich kann da mangels Erfahrung wenig zu sagen, aber es kann schon sein, dass die Einstellungen bei Neueinwahl zurückgesetzt werden, da du ja damit quasi jedes Mal eine neue Verbindung aufbaust.

Stimmt, ich baue eine direkte Verbindung über das Modem auf. Wenn sich das oben beschriebene Problem noch lösen lässt wäre ich schon froh, wenn ich diese Einstellungen nicht jedes mal wieder von neuem vornehmen müsste.

Noch ein Satz zum Schluss: Ich kenne mich da wirklich nicht aus, aber ich habe herausgefunden, dass sich die Einträge in der routing-tabelle auch einzeln verändern lassen (route change), bzw permanent hinzufügen lassen (route add /p). Mein Gefühl sagt mir, dass die Lösung irgendwo da liegen muss, aber dazu müsste man eine Ahnung haben, welche der vielen Einträge wie modifiziert werden müssten...

Vielen Dank!
Jens

Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher